const regex = /^((?!\.)[\w\-_+.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!\\.)[\\w\\-_+.]*[^.])(@\\w+)(\\.\\w+(\\.\\w+)?[^.\\W])$', 'gm')
const str = `lama.loca.loca123@inca.com
this+is+valid@email.com
pio_pio@factory.com
carnival666@hellmail.com
la-lalai@gmail.com
//INVALID EMAILS
//spaces at start
testmail@mail.com
//start with points
.testmail@mail.com
//finish with points
testmail@mail.com.
//spaces into the string
testm ail@mail.com
//Start/finish with any not number|letter char
testmail@mail.com.de
testmail@mail.de.org`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}