const regex = /^\s*-----BEGIN PGP MESSAGE-----\s*(?:(Charset:.*\n)|(Version:.*\n)|(Comment:.*\n))*\s*(?:(?:[A-Za-z0-9+\/]{4}\n?)*(?:[A-Za-z0-9+\/]{2}==|[A-Za-z0-9+\/]{3}=))\n(?:=(?:[A-Za-z0-9+\/]{4}\n?)?)\s*-----END PGP MESSAGE-----\s$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*-----BEGIN PGP MESSAGE-----\\s*(?:(Charset:.*\\n)|(Version:.*\\n)|(Comment:.*\\n))*\\s*(?:(?:[A-Za-z0-9+\\\/]{4}\\n?)*(?:[A-Za-z0-9+\\\/]{2}==|[A-Za-z0-9+\\\/]{3}=))\\n(?:=(?:[A-Za-z0-9+\\\/]{4}\\n?)?)\\s*-----END PGP MESSAGE-----\\s$', '')
const str = `-----BEGIN PGP MESSAGE-----
Version: OpenPGP.js v4.10.4
Comment: https://openpgpjs.org
wV4DvfxLq4XF8ggSAQdA4vSDKaF+rOKWmS/JG36qiH9AxUZoAIbCw922l2lG
2C4w/KefQjcbu+Tv3ymV0Dtfm3702tWK6CIiMr0cCu7iBfZqZ7JOEaOJfEzz
0NoSwo080kIBHSs5HLQOj89Ra0A2QgHKV5lsOZGDVlpgZZjQFGL+p+Vc/hJT
+Moh7JGYof6YD4u9ueDWCbgSXbMsvbWcitjnjdU=
=wC/C
-----END PGP MESSAGE-----
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}