// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\s*-----BEGIN PGP MESSAGE-----\s*(?:(Charset:.*\n)|(Version:.*\n)|(Comment:.*\n))*\s*(?:(?:[A-Za-z0-9+\/]{4}\n?)*(?:[A-Za-z0-9+\/]{2}==|[A-Za-z0-9+\/]{3}=))\n(?:=(?:[A-Za-z0-9+\/]{4}\n?)?)\s*-----END PGP MESSAGE-----\s$").unwrap();
let string = "-----BEGIN PGP MESSAGE-----
Version: OpenPGP.js v4.10.4
Comment: https://openpgpjs.org
wV4DvfxLq4XF8ggSAQdA4vSDKaF+rOKWmS/JG36qiH9AxUZoAIbCw922l2lG
2C4w/KefQjcbu+Tv3ymV0Dtfm3702tWK6CIiMr0cCu7iBfZqZ7JOEaOJfEzz
0NoSwo080kIBHSs5HLQOj89Ra0A2QgHKV5lsOZGDVlpgZZjQFGL+p+Vc/hJT
+Moh7JGYof6YD4u9ueDWCbgSXbMsvbWcitjnjdU=
=wC/C
-----END PGP MESSAGE-----
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}