const regex = /^"?([^\s"@]+?@[^\s"@]+)"? +<(?!\1>)[^>]*>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"?([^\\s"@]+?@[^\\s"@]+)"? +<(?!\\1>)[^>]*>$', 'gm')
const str = `##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < DOSE NOT CONTAIN @
this example <this@example.com>
"this example" <this@example.com>
Name <this@example.com>
"Name" <this@example.com>
this@example.com
<this@example.com>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS @, HOWEVER BOTH STRINGS ARE IDENTICAL
"this@example.tld" <this@example.tld>
this@example.tld <this@example.tld>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS SPACE
"random @ other.com" <this@example.tld>
random @ other.com <this@example.tld>
#THESE SHOULD MATCH
alpha@example.com <beta@example.com>
"alpha@example.com" <beta@example.net>
alpha@other.tld <beta@example.com>
"alpha@other.tld" <alpha@example.com>
prefix@example.edu <prefix@example.edu.com>
"prefix@example.edu" <prefix@example.edu.com>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}