# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\"?([^\s\"@]+?@[^\s\"@]+)\"? +<(?!\1>)[^>]*>$"
test_str = ("##THESE SHOULD NOT MATCH\n"
"###PART BEFORE THE LAST < DOSE NOT CONTAIN @\n"
"this example <this@example.com>\n"
"\"this example\" <this@example.com>\n"
"Name <this@example.com>\n"
"\"Name\" <this@example.com>\n"
"this@example.com\n"
" <this@example.com>\n\n"
"##THESE SHOULD NOT MATCH\n"
"###PART BEFORE THE LAST < CONTAINS @, HOWEVER BOTH STRINGS ARE IDENTICAL\n"
"\"this@example.tld\" <this@example.tld>\n"
"this@example.tld <this@example.tld>\n\n"
"##THESE SHOULD NOT MATCH\n"
"###PART BEFORE THE LAST < CONTAINS SPACE\n"
"\"random @ other.com\" <this@example.tld>\n"
"random @ other.com <this@example.tld>\n\n\n"
"#THESE SHOULD MATCH\n"
"alpha@example.com <beta@example.com>\n"
"\"alpha@example.com\" <beta@example.net>\n"
"alpha@other.tld <beta@example.com>\n"
"\"alpha@other.tld\" <alpha@example.com>\n"
"prefix@example.edu <prefix@example.edu.com>\n"
"\"prefix@example.edu\" <prefix@example.edu.com>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.