#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<= )[A-Za-z ]+(?=,? [A-Z]{2})"
Local $sString = "6301 Stonewood Dr Apt-728, Plano TX-75024 " & @CRLF & _
"13323 Maham Road, Apt # 1621, Dallas, TX 75240" & @CRLF & _
"17040 Carlson Drive, #1027 Parker, CO 80134" & @CRLF & _
"3465 25th St., San Francisco, CA 94110 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")