# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<= )[A-Za-z ]+(?=,? [A-Z]{2})"
test_str = ("6301 Stonewood Dr Apt-728, Plano TX-75024 \n"
"13323 Maham Road, Apt # 1621, Dallas, TX 75240\n"
"17040 Carlson Drive, #1027 Parker, CO 80134\n"
"3465 25th St., San Francisco, CA 94110 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.