#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^|]+\|\s*([^|]+?)\s*\|.*"
Local $sString = "20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |" & @CRLF & _
"20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:" & @CRLF & _
"20198818-119903 | test4| passed :| host | is connected to a test with 333" & @CRLF & _
"20198818-119903 | something | passed : host test-1000 is connected to a test with Version:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")