import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^|]+\\|\\s*([^|]+?)\\s*\\|.*";
final String string = "20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |\n"
+ "20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:\n"
+ "20198818-119903 | test4| passed :| host | is connected to a test with 333\n"
+ "20198818-119903 | something | passed : host test-1000 is connected to a test with Version:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}