$re = '/\b[0-9]{4,}|379|3[8-9][0-9]|[4-9][0-9]{2}\b/m';
$str = '370 378 379 379379 380 399 400 4001 4999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);