// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[0-9]{4,}|379|3[8-9][0-9]|[4-9][0-9]{2}\b").unwrap();
let string = "370 378 379 379379 380 399 400 4001 4999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}