using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(dev-|stag-|)(assets|images).server\.io\/v\d\/file\/(.*?)\/(?!download$)[^\/]+$";
string input = @"https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg
https://images.server.io/v3/file/blt123e25b85f95497/download
https://images.server.io/v3/file/blt123e25b85f95497/random.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}