import Foundation
let pattern = #"https:\/\/(dev-|stag-|)(assets|images).server\.io\/v\d\/file\/(.*?)\/(?!download$)[^\/]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg
https://images.server.io/v3/file/blt123e25b85f95497/download
https://images.server.io/v3/file/blt123e25b85f95497/random.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)