use strict;
my $str = 'https://assets.server.io/v3/file/blt123e25b85f95497/download.jpg
https://images.server.io/v3/file/blt123e25b85f95497/download
https://images.server.io/v3/file/blt123e25b85f95497/random.jpg';
my $regex = qr/https:\/\/(dev-|stag-)?(assets|images)\.server\.io\/v\d\/file\/(.*?)\/(?!download$)[^\/]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}