import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s\\((.*?\\d{4}.*?)\\)";
final String string = " and the reported results in (Nivre et al., 2007) were not representative ...\n"
+ "... two systems used a Markov chain approach (Sagae and Tsujii 2007).\n"
+ "Nivre (2007) showed that ...\n"
+ "... for attaching and labeling dependencies (Chen et al., 2007; Dredze et al., 2007).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}