$re = '/\s\((.*?\d{4}.*?)\)/m';
$str = ' and the reported results in (Nivre et al., 2007) were not representative ...
... two systems used a Markov chain approach (Sagae and Tsujii 2007).
Nivre (2007) showed that ...
... for attaching and labeling dependencies (Chen et al., 2007; Dredze et al., 2007).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);