package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\p{L}'-]{2,}(?:\s[\p{L}'-]+)?\s[\p{L}'-]{2,}`)
var str = `Jonny Nott, Name Here, Jonathan M Notty`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}