$re = '/[\p{L}\'-]{2,}(?:\s[\p{L}\'-]+)?\s[\p{L}\'-]{2,}/';
$str = 'Jonny Nott, Name Here, Jonathan M Notty';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);