const regex = /(?<=.)[^@\n](?=[^@\n]*?@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.)[^@\\n](?=[^@\\n]*?@)|(?:(?<=@.)|(?!^)\\G(?=[^@\\n]*$)).(?!$)', 'gm')
const str = `john.doe@example.en.com
foo@bar.com
foo-and.more!here@bar.com
fo@bar.com
f@bar.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);