re = /(?<=.)[^@\n](?=[^@\n]*?@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?!$)/m
str = 'john.doe@example.en.com
foo@bar.com
foo-and.more!here@bar.com
fo@bar.com
f@bar.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result