const regex = /(?=(?:.*?[a-z]){5})(?=(?:.*?\d){4})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:.*?[a-z]){5})(?=(?:.*?\\d){4})', 'i')
const str = `ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}