# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(?:.*?[a-z]){5})(?=(?:.*?\d){4})"
test_str = ("ffffasfsaf242343242\n"
"2vv4fj222\n"
"555553jjjjjj\n"
"fdsfafadsfdf\n"
"234234324232\n"
"4444fasdfasf\n"
"3j3j3j3j3j3\n"
"11111jjjjjnnn\n"
"ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.