$re = '/(.+?)( - |$)/m';
$str = 'BIG ROOM - LADIES - PRIMETIME - SAFER';
$subst = "[$1] ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;