re = /(.+?)( - |$)/m
str = 'BIG ROOM - LADIES - PRIMETIME - SAFER'
subst = '[$1] '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result