$re = '/[A-ZÀ-Ú]/m';
$str = '× <-- multiplication sign (não é a letra "x")
Ð <-- letra "eth"
Æ
--- letras deixadas de fora:
Û
Ü
Ý';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);