using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"errorDescription\""\:\""(?<errorDescription>[^\""]+).+errorCode\""\:\""(?<errorCode>[^\""]+)";
string input = @"2016-10-25 12:33:31,926 [http-00000:13111-2] INFO [org.apache.cxf.interceptor.LoggingInInterceptor ?] Inbound Message ----------------------------
ID: 18 Response-Code: 200
Encoding: UTF-8
Content-Type: application/json;charset=UTF-8
Headers: {content-type=[application/json;charset=UTF-8], Date=[Tue, 25 Oct 2016 17:33:30 GMT], Expires=[Thu, 01 Jan 1970 00:00:00 GMT], Set-Cookie=[BrowserId=L8p9Eij0T4Sfp-INSP9zDw;Path=/;Domain=.salesforce;Expires=Sat, 24-Dec-2016 17:33:30 GMT], transfer-encoding=[chunked]}
Payload: {""responseCode"":""201"",""messageId"":""704c8163-13d4-42b8-a684-94b9d23e849e"",
""lead"":[{""responseCode"":""201"",""leadID"":null,""errors"":[{""errorField"":""head"",""errorDescription"":""The value of email is invalid."",""errorCode"":""Value_Invalid_E400""},{""errorField"":""bestTimeToContact"",""errorDescription"":""The value of bestTimeToContact is invalid."",""errorCode"":""Value_Invalid_E400""}]}]}
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
2016-10-25 12:33:31,986 [http-000000:13111-2] INFO [org.apache.cxf.interceptor.LoggingOutInterceptor ?] Outbound Message ---------------------------
ID: 17
Response-Code: 200
Content-Type: application/json
Headers: {Content-Type=[application/json], Date=[Tue, 25 Oct 2016 17:33:31 GMT]}
Payload: {""errors"":[{""errorCode"":""Value_Invalid_E400"",""errorDescription"":""The value of email is invalid."",""errorField"":""head""},{""errorCode"":""Value_Invalid_E400"",""errorDescription"":""The value of bestTimeToContact is invalid."",""errorField"":""bestTimeToContact""}]} --------------------------------------";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}