import re
regex = re.compile(r"errorDescription\"\:\"(?<errorDescription>[^\"]+).+errorCode\"\:\"(?<errorCode>[^\"]+)")
test_str = ("2016-10-25 12:33:31,926 [http-00000:13111-2] INFO [org.apache.cxf.interceptor.LoggingInInterceptor ?] Inbound Message ---------------------------- \n"
" ID: 18 Response-Code: 200\n"
" Encoding: UTF-8 \n"
" Content-Type: application/json;charset=UTF-8\n"
" Headers: {content-type=[application/json;charset=UTF-8], Date=[Tue, 25 Oct 2016 17:33:30 GMT], Expires=[Thu, 01 Jan 1970 00:00:00 GMT], Set-Cookie=[BrowserId=L8p9Eij0T4Sfp-INSP9zDw;Path=/;Domain=.salesforce;Expires=Sat, 24-Dec-2016 17:33:30 GMT], transfer-encoding=[chunked]} \n"
" \n"
" Payload: {\"responseCode\":\"201\",\"messageId\":\"704c8163-13d4-42b8-a684-94b9d23e849e\",\n"
" \"lead\":[{\"responseCode\":\"201\",\"leadID\":null,\"errors\":[{\"errorField\":\"head\",\"errorDescription\":\"The value of email is invalid.\",\"errorCode\":\"Value_Invalid_E400\"},{\"errorField\":\"bestTimeToContact\",\"errorDescription\":\"The value of bestTimeToContact is invalid.\",\"errorCode\":\"Value_Invalid_E400\"}]}]} \n"
" ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------\n"
" 2016-10-25 12:33:31,986 [http-000000:13111-2] INFO [org.apache.cxf.interceptor.LoggingOutInterceptor ?] Outbound Message --------------------------- \n"
" ID: 17 \n"
" Response-Code: 200 \n"
" Content-Type: application/json\n"
" Headers: {Content-Type=[application/json], Date=[Tue, 25 Oct 2016 17:33:31 GMT]}\n"
" Payload: {\"errors\":[{\"errorCode\":\"Value_Invalid_E400\",\"errorDescription\":\"The value of email is invalid.\",\"errorField\":\"head\"},{\"errorCode\":\"Value_Invalid_E400\",\"errorDescription\":\"The value of bestTimeToContact is invalid.\",\"errorField\":\"bestTimeToContact\"}]} --------------------------------------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")