package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:\d{3}\.)+\d{3}\b`)
var str = `234.567
123.45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}