$re = '/\b(?:\d{3}\.)+\d{3}\b/m';
$str = '234.567
123.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);