re = /<[^>]*>/m
str = ' <li id="ctl00_LeftNavigation1_LeftMenu_ctl00_ListItem1" class="starLink"><a href=\'/CheatSheet.aspx\'>Regex Cheat Sheet</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl02_ListItem1"><a href=\'/Search.aspx\'>Search</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl03_ListItem1"><a href=\'/RETester.aspx\'>Regex Tester</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl04_ListItem1"><a href=\'/DisplayPatterns.aspx\'>Browse Expressions</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl05_ListItem1"><a href=\'/Add.aspx\'>Add Regex</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl06_ListItem1"><a href=\'/UserPatterns.aspx\'>Manage My Expressions</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl07_ListItem1"><a href=\'/Contributors.aspx\'>Contributors</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl11_ListItem1"><a href=\'/Resources.aspx\'>Regex Resources</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl12_ListItem1"><a href=\'/WebServices.asmx\'>Web Services</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl13_ListItem1"><a href=\'http://lakequincy.com/advertisers/publisherinfo/regExLib.aspx\'>Advertise</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl14_ListItem1"><a href=\'/Contact.aspx\'>Contact Us</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl15_ListItem1"><a href=\'/Register.aspx\'>Register</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl16_ListItem1" class="rssLink"><a href=\'http://feeds.feedburner.com/Regexlibcom-RecentPatterns\'>Recent Expressions</a></li>
<li id="ctl00_LeftNavigation1_LeftMenu_ctl17_ListItem1" class="rssLink"><a href=\'http://feeds.feedburner.com/Regexlibcom-RecentComments\'>Recent Comments</a></li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end