package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D`)
var str = `+144-(22)-13=0x6D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}