$re = '/\D/';
$str = '+144-(22)-13=0x6D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);