$re = '/(?i)(?<=\d{2} - ).{2,50}(?= \()/m';
$str = 'Zimne błyskotki gwiazd - 02 - Gwiezdny cień (1998)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);