re = /(?i)(?<=\d{2} - ).{2,50}(?= \()/m
str = 'Zimne błyskotki gwiazd - 02 - Gwiezdny cień (1998)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end