#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S+\d\.\d+"
Local $sString = "Internet Uplink FON 41.79.9.117 : Successful" & @CRLF & _
"Microtik 194.201.253.246 : Successful" & @CRLF & _
"Rooftop Switch 213.150.96.166: Successful" & @CRLF & _
"" & @CRLF & _
" TELNET TEST" & @CRLF & _
" telnet mail.kenyaweb.com 25 : Connected to mail.kenyaweb.com. Escape character is '^]'. 220 mail.kenyaweb.com ESMTP Postfix" & @CRLF & _
" telnet mail.kenyaweb.com 110: Connected to mail.kenyaweb.com. Escape character is '^]'. +OK POP3 ready" & @CRLF & _
"" & @CRLF & _
" MAIL SERVERS" & @CRLF & _
" mail.kenyaweb.com 194.201.253.165 : Successful" & @CRLF & _
" Relay.kenyaweb.com 194.201.253.124 : Successful" & @CRLF & _
" pop.kenyaweb.com 194.201.253.11 : Successful" & @CRLF & _
" hosting.kenyaweb.com 194.201.253.132 : Successful" & @CRLF & _
"" & @CRLF & _
" WEB SERVERS" & @CRLF & _
"Web server 1 194.201.253.70 : Successful" & @CRLF & _
"Web server 2 194.201.253.8 : Successful" & @CRLF & _
"Web Server 3 194.201.253.5 : Successful" & @CRLF & _
"sungura.kenyaweb.com 192.64.112.132: Successful" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" DNS" & @CRLF & _
" Linux.form-net.com 194.201.253.105 : Successful" & @CRLF & _
" ns200.kenyaweb.com 194.201.253.186 : Successful" & @CRLF & _
" ns201.kenyaweb.com 194.201.253.189 : Successful" & @CRLF & _
" ns203.kenyaweb.com 63.250.47.221 : Successful" & @CRLF & _
"" & @CRLF & _
" BROWSE TEST" & @CRLF & _
" www.kenyaweb.com http://www.kenyaweb.com : Successful" & @CRLF & _
" www.yahoo.com http://www.yahoo.com : Successful" & @CRLF & _
" www.google.com http://www.google.com : Successful" & @CRLF & _
"" & @CRLF & _
" MAIL TEST" & @CRLF & _
" Mail.Kenyaweb to yahoo : Received" & @CRLF & _
" Mail.Kenyaweb to gmail : Received" & @CRLF & _
" Yahoo to Mail.Kenyaweb : Received" & @CRLF & _
" Gmail to Mail.Kenyaweb : Received"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")