import re
regex = re.compile(r"\S+\d\.\d+", flags=re.MULTILINE)
test_str = ("Internet Uplink FON 41.79.9.117 : Successful\n"
"Microtik 194.201.253.246 : Successful\n"
"Rooftop Switch 213.150.96.166: Successful\n\n"
" TELNET TEST\n"
" telnet mail.kenyaweb.com 25 : Connected to mail.kenyaweb.com. Escape character is '^]'. 220 mail.kenyaweb.com ESMTP Postfix\n"
" telnet mail.kenyaweb.com 110: Connected to mail.kenyaweb.com. Escape character is '^]'. +OK POP3 ready\n\n"
" MAIL SERVERS\n"
" mail.kenyaweb.com 194.201.253.165 : Successful\n"
" Relay.kenyaweb.com 194.201.253.124 : Successful\n"
" pop.kenyaweb.com 194.201.253.11 : Successful\n"
" hosting.kenyaweb.com 194.201.253.132 : Successful\n\n"
" WEB SERVERS\n"
"Web server 1 194.201.253.70 : Successful\n"
"Web server 2 194.201.253.8 : Successful\n"
"Web Server 3 194.201.253.5 : Successful\n"
"sungura.kenyaweb.com 192.64.112.132: Successful\n"
" \n\n"
" DNS\n"
" Linux.form-net.com 194.201.253.105 : Successful\n"
" ns200.kenyaweb.com 194.201.253.186 : Successful\n"
" ns201.kenyaweb.com 194.201.253.189 : Successful\n"
" ns203.kenyaweb.com 63.250.47.221 : Successful\n\n"
" BROWSE TEST\n"
" www.kenyaweb.com http://www.kenyaweb.com : Successful\n"
" www.yahoo.com http://www.yahoo.com : Successful\n"
" www.google.com http://www.google.com : Successful\n\n"
" MAIL TEST\n"
" Mail.Kenyaweb to yahoo : Received\n"
" Mail.Kenyaweb to gmail : Received\n"
" Yahoo to Mail.Kenyaweb : Received\n"
" Gmail to Mail.Kenyaweb : Received")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")