package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+\s(\S+)`)
var str = `Brand1 article924 Simple name position
Brand5 article455 Simple name position
Brand64 article963 Simple name position
Brand123 article567 Simple name position
Brand274 article731 Simple name position
Brand399 article844 Simple name position`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}