const regex = /^\S+\s(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\S+\\s(\\S+)', 'gm')
const str = `Brand1 article924 Simple name position
Brand5 article455 Simple name position
Brand64 article963 Simple name position
Brand123 article567 Simple name position
Brand274 article731 Simple name position
Brand399 article844 Simple name position`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}