using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""https:.*(\/)([^\/]+)(?:(?=\/""))\/";
string substitution = @"<a href=""\2.html";
string input = @"<li id=""menu-item-1755"" class=""menu-item menu-item-type-post_type menu-item-object-page menu-item-1755""><a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/secrets-of-print-on-demand/"" itemprop=""url"" class=""wpc-lesson wpc-lesson-1754 wpc-lesson-complete"">BONUS VIDEO! The Secrets Of 6-Figure & 7-Figure Print On Demand Products</a></li>
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/dashboard/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/introduction/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-1-brainstorming-a-niche/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-2-narrow-down-your-niches/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-3-picking-your-winning-niche/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/how-to-select-a-store-name/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-pick-aliexpress-products-to-sell/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-select-the-right-aliexpress-supplier/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-find-print-on-demand-designs-to-sell-2/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-get-a-design-on-fiverr/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/create-free-designs/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-get-a-design-on-shutterstock/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-price-products/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/secrets-of-print-on-demand/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-shopify-account/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-the-theme/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-oberlo-update-its-settings/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-the-chrome-extension/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-products-with-oberlo/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-printify-account/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-product-with-printify/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-update-product-pages/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-collections/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-an-about-us-page/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-an-contact-us/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-refund-policy-page/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-set-up-payments/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/add-legal-pages/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-menus/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-logo/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-customize-theme-homepage/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-add-shipping-2/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-edit-confirmation-email-2/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-add-facebook-live-chat/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-buy-a-domain-name-2/""
<a href=""https://members.theecommclubhouse.com/step-3/how-to-remove-store-password-2/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-sales-pop/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-trust-icons/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-smar7-bundle-upsell/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-spin-a-wheel-app/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-after-sale-coupons/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/introduction-to-facebook/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-business-account/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-fanpage/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-install-the-facebook-pixel/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/lifestyle-images-print-on-demand/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-showcase-video-ad/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-edit-a-showcase-video-ad/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-an-example-video-ad/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-an-image-ad/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-video-ad-2/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-scale-facebook-ads/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-get-free-seo-traffic-from-google/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-find-low-competition-keywords/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-product-pages/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-product-category-pages/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-your-homepage/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-add-optimize-blog-posts/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-build-backlinks-with-instagram-pages/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-fulfill-orders-with-oberlo/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-fulfill-orders-with-printify/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/daily-store-management-growth/""
<a href=""https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-hire-freelancers/""
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}