# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a href=\"https:.*(\/)([^\/]+)(?:(?=\/\"))\/"
test_str = ("<li id=\"menu-item-1755\" class=\"menu-item menu-item-type-post_type menu-item-object-page menu-item-1755\"><a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/secrets-of-print-on-demand/\" itemprop=\"url\" class=\"wpc-lesson wpc-lesson-1754 wpc-lesson-complete\">BONUS VIDEO! The Secrets Of 6-Figure & 7-Figure Print On Demand Products</a></li>\n\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/dashboard/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/introduction/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-1-brainstorming-a-niche/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-2-narrow-down-your-niches/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/phase-3-picking-your-winning-niche/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-1/how-to-select-a-store-name/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-pick-aliexpress-products-to-sell/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-select-the-right-aliexpress-supplier/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-find-print-on-demand-designs-to-sell-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-get-a-design-on-fiverr/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/create-free-designs/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-get-a-design-on-shutterstock/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/how-to-price-products/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-2/secrets-of-print-on-demand/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-shopify-account/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-the-theme/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-oberlo-update-its-settings/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-install-the-chrome-extension/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-products-with-oberlo/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-printify-account/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-product-with-printify/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-update-product-pages/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-collections/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-an-about-us-page/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-an-contact-us/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-refund-policy-page/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-set-up-payments/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/add-legal-pages/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-add-menus/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-3/how-to-create-a-logo/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-customize-theme-homepage/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-add-shipping-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-edit-confirmation-email-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-add-facebook-live-chat/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-buy-a-domain-name-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/step-3/how-to-remove-store-password-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-sales-pop/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-trust-icons/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-smar7-bundle-upsell/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-spin-a-wheel-app/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-4/how-to-add-after-sale-coupons/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/introduction-to-facebook/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-business-account/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-fanpage/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-install-the-facebook-pixel/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/lifestyle-images-print-on-demand/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-showcase-video-ad/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-edit-a-showcase-video-ad/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-an-example-video-ad/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-an-image-ad/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-create-a-facebook-video-ad-2/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-scale-facebook-ads/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-get-free-seo-traffic-from-google/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-find-low-competition-keywords/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-product-pages/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-product-category-pages/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-optimize-your-homepage/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-add-optimize-blog-posts/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-5/how-to-build-backlinks-with-instagram-pages/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-fulfill-orders-with-oberlo/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-fulfill-orders-with-printify/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/daily-store-management-growth/\"\n"
"<a href=\"https://members.theecommclubhouse.com/ecomm-clubhouse/step-6/how-to-hire-freelancers/\"\n")
subst = "<a href=\"\\2.html"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.