#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\w+)\2).*?\1.*"
Local $sString = "Tumble Trouble Twwixt Two Towns!" & @CRLF & _
"Was the Moon soon in the Sea" & @CRLF & _
"Or soon in the sky?" & @CRLF & _
"Nobody really knows YET." & @CRLF & _
"" & @CRLF & _
"Test abab test abab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")