import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\w+)\\2).*?\\1.*";
final String string = "Tumble Trouble Twwixt Two Towns!\n"
+ "Was the Moon soon in the Sea\n"
+ "Or soon in the sky?\n"
+ "Nobody really knows YET.\n\n"
+ "Test abab test abab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}