using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:|(https?:\/\/)?(|www)[.]?)(?:t|telegram)\.(?:me|dog)/(joinchat/|\+)?([\w-]+)";
string input = @"https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
t.me/I5antRHvea8ohaU7_RsYYQ
t.dog/I5antRHvea8ohaU7_RsYYQ
https://t.dog/I5antRHvea8ohaU7_RsYYQ
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}