re = /^(?:|(https?:\/\/)?(|www)[.]?)(?:t|telegram)\.(?:me|dog)\/(joinchat\/|\+)?([\w-]+)/im
str = 'https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
t.me/I5antRHvea8ohaU7_RsYYQ
t.dog/I5antRHvea8ohaU7_RsYYQ
https://t.dog/I5antRHvea8ohaU7_RsYYQ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end