using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)""""([^""]*?xyz).*?""""";
string input = @"""""
blah blah
blah
xyz
blah blah
""""
""""
blah blah blah
blah
""""
# xyz
def foo(self):
""""
blah
""""
-----------------
no xyz no
""""
yes xyz yes
""""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}