re = /(?ms)"""([^"]*?xyz).*?"""/
str = '"""
blah blah
blah
xyz
blah blah
"""
"""
blah blah blah
blah
"""
# xyz
def foo(self):
"""
blah
"""
-----------------
no xyz no
"""
yes xyz yes
"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end