$re = '/\w+(?:-+\w+){2,}/m';
$str = 'http://time.com/this----time-is-different';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);