using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D)(?=\d)|(?<=\d)(?=\D)";
string substitution = @" ";
string input = @"a3:2bc/12.3\efg;123.12a:5,|i(+/-)j.
BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)
Text
ibuprofen
ibuprofen;
ibuprofen.
ibuprofen:
ibuprofen(Ibumetin)
ibuprofen,enalapril
ibuprofen|enalapril
:ibuprofen
-ibumetin,
ibuprofen/enalapril
ibuprofen / enalapril
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}