$re = '/[#@&$]a[#@&$](?<!@a\$)/m';
$str = '@a@
#a@
$a$
but not a specific pattern @a$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);