re = /[#@&$]a[#@&$](?<!@a\$)/m
str = '@a@
#a@
$a$
but not a specific pattern @a$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end